To run the PsoVis Applet you need to have the Java 3D package installed on your computer

PsoVis Applet

. Your browser is completely ignoring the <APPLET> tag!